Third-Party Payment Service Disruption: iDEAL
Incident Report for Mangopay API
Resolved
This incident has been resolved.
Posted Jul 01, 2024 - 19:45 UTC
Investigating
We are currently monitoring a disruption affecting iDEAL: Partial Service Disruption
We are working with the external partner to resolve the issue and will provide updates as they become available.
Posted Jul 01, 2024 - 18:37 UTC