Issues with IDEAL Payments
Incident Report for Mangopay API
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 21:17 UTC
Identified
We have been informed of issues with iDEAL for ABN AMRO starting at 14:15CET.
https://availability.ideal.nl/History?bank=ABN_AMRO
Updates to follow.
Posted Mar 21, 2024 - 17:41 UTC
This incident affected: Production (Acquirer/Payments performance).