[PRODUCTION] Disturbance on Giropay payments (PSP brick)
Incident Report for Mangopay API
Resolved
As part of our ongoing efforts to ensure the best possible payment experience for our customers, we recently conducted an investigation into our Giropay payments system following this incident.
Through this process, we discovered areas to improve the system and provide a better service.

After careful consideration, we decided to route Giropay payments to a new partner. This partner has been carefully vetted and selected based on their track record of providing reliable, secure, and efficient payment processing services. We are confident that this change will result in a smoother and more streamlined payment experience for our customers.

We would like to thank you for your patience and understanding during this transition period. If you have any questions or concerns about this change, please don't hesitate to contact us.
Posted Dec 04, 2023 - 10:47 UTC
Update
We are currently conducting a thorough investigation with GIROPAY directly in order to identify the root cause of the issue. Their IT team is actively involved in the process and working to resolve the situation as quickly as possible. We will provide regular updates as we receive more information on the matter.
Posted Oct 19, 2023 - 08:30 UTC
Investigating
Payments using Giropay in the PRODUCTION environment may be affected.
"101199 - Transaction refused" errors since 05:00 AM UTC 01/09 are due to an issue with our PSP component.

We are investigating and will update you.

Details:
- Affected users: Anyone using Giropay in PRODUCTION
- Affected payment types: Giropay.
Posted Oct 16, 2023 - 12:48 UTC