[PRODUCTION] Disturbance on Payments - Increased API Response Times
Incident Report for Mangopay API
Resolved
This incident has been resolved.
Posted Jun 11, 2024 - 14:12 UTC
Investigating
You may experience increased response times on payments since 7:30 AM CET. These disruptions are a result of an ongoing incident linked to our PSP provider's recent maintenance.
Posted Jun 11, 2024 - 08:53 UTC
This incident affected: Production (Acquirers and payment methods).