As of 10:51 AM UTC, we have stabilized the error rate for "PSP Technical Error". However, we are not resting until the situation is fully resolved, and we are working closely with our PSP partner to achieve this. Rest assured, we will keep you informed every step of the way.
Posted Nov 09, 2023 - 11:07 UTC
Identified
We have identified the issue to be originating from our payment service provider partner, and we are taking all necessary measures to swiftly resolve the situation. We are closely monitoring the progress and will keep you updated as soon as we have more information.
Posted Nov 09, 2023 - 10:45 UTC
Investigating
Attention all users in the production environment,
we are aware of the "PSP Technical Error" errors that have been affecting payments since 10:11 AM UTC. We want to assure you that our team is actively investigating the issue and working to resolve it as soon as possible. We apologize for any inconvenience this may have caused and we will keep you updated with any new information.
• Who is affected: Anyone in the PRODUCTION/SANDBOX environment.