[PRODUCTION] Disturbance on payments (PSP brick)
Incident Report for Mangopay API
Resolved
This incident has been resolved.
Posted Mar 23, 2023 - 17:14 UTC
Monitoring
Our partner identified their network connectivity issue and deployed a fix.
The payment flow is getting back to normal since 16:36 UTC.

We are monitoring the situation with our partner.
Posted Mar 23, 2023 - 16:55 UTC
Update
The incident with our PSP partner and Mastercard is now reaching all their flow of transactions and is not only impacting Mastercard payments.
Therefore we are investigating the connectivity issues with them.

You are experiencing the following PSP Technical Errors on the following payment methods:
- CB
- VISA
- MASTERCARD
- IDEAL
- MAESTRO
- BCMC
Posted Mar 23, 2023 - 16:35 UTC
Identified
The issue has been identified to be impacting Mastercard only and not VISA.
We are in contact with them regarding the resolution of the incident.
Posted Mar 23, 2023 - 16:01 UTC
Investigating
You may experience "PSP Technical Error" and "Secure mode: The 3DSecure authentication has failed" errors on payments since 15:20 UTC.

These disturbances are due to an issue with 3DS authentication with the following schemes: VISA & Mastercard
Investigations are ongoing with said card schemes.

• Who is affected: Anyone in the PRODUCTION environment.
Posted Mar 23, 2023 - 15:41 UTC
This incident affected: Production (PSP brick).