[Production] Issue on bank statement description for Payins
Incident Report for Mangopay Api
Postmortem

Incident history

  • July 2 at 4pm UTC | Our Fraud and technical assistance teams pointed out wrong bank statements on screenshots and escalated the suspicion.
  • July 2 at 6pm UTC | After investigations MANGOPAY came to the conclusion that it was caused by the release of our Payment Service Provider made on june 27 at 4:30am UTC.
  • July 2 at 8:15pm UTC | The Payment Service Provider published a hotfix. No more issue since then.

Root cause

  • The update published by our payment service provider has directly affected our service by changing the statements payment labels we send to the bank.

Service during the incident

  • From June 27 at 4:30am UTC to July 2 at 8:15pm UTC, customers who payed on your platform might have received an incorrect description of the payment in bank instead of the name of your platform.

Actions and recovery

We strongly advise you to inform your customers that their payments between June 27 and July 2 may have an unknown bank statement. They should indeed check the amount and the date and probably contact you in case of a doubt. This action can definitely prevent chargebacks.


MANGOPAY apologizes for this external issue that could have impact on your activity. Be sure that MANGOPAY will deploy appropriate measures to prevent such incident in the future. Feel free to reach out if you have any questions.

Posted 5 months ago. Jul 04, 2018 - 09:49 CEST

Resolved
This incident is now fixed.

Please note this incident ticket will be updated with a postmortem in order to provide more details.
Posted 5 months ago. Jul 02, 2018 - 21:15 CEST
Investigating
.
• We noticed an issue with bank statement descriptors for Payins. Indeed, some of them seem to be displayed with an incorrect statement, indicating "Mangopay" instead of your company name on the end-users bank. Our team, the PSP and all involved partners are investigating.
• Who is affected: Anyone might be affected on PRODUCTION environment.
• Date: Not identified
Posted 5 months ago. Jul 02, 2018 - 18:48 CEST
This incident affected: MANGOPAY Production API.